Introduction: Motorola SM56 Software Modem User's Guide

Key Features

Thank you for using the SM56 Modem. The modem supports V.90/V.92 and K56flex™ connections, providing high-speed communications between your personal computer and a remote location. You can:

• Receive data at up to 56.0 Kbps in V.90/V.92 or K56flex™ mode, for fast Internet access

• Use your computer to send and receive faxes, at up to 14.4 Kbps

• Use your computer as a Video Phone, to place and receive Video Phone calls

• Use your computer as a telephone answering machine (Not available on Data/Fax modems.)

• Use your computer as a speakerphone, to place and receive voice calls (Data/Fax/Speakerphone modem only.)

• Refer to your computer’s voice application user’s manual to use the answering machine and speakerphone features.

What type of modem do I have?

NOTE: The SM56 is capable of 56Kbps connections, but due to various telephone line impairments, speeds in actual use maybe less.

Key Features

The modem supports:

• The V.90/V.92 56K standard and K56flex, for maximum ISP interoperability

• V.44 Data compression for the highest Internet download speeds from participating ISPs

• The V.80 interface to H.234-compliant Video Phone applications

• The V.34, V.32bis, V.32, V.23, V.22bis, V.22, V.21, Bell 212A, and Bell 103 modulation standards

• Fax Class 1 error-correction mode

• V.17, V.21, V.29, V.27ter Group III Fax modes

• V.42, LAP-M, and MNP 2-4 error-correction protocols

• V.42bis and MNP 5 data-compression protocols

• DTE rates from 300 bps to 115.2 Kbps

The modem is designed with easy upgrades in mind. You can upgrade the modem software with a simple Internet download to help keep up with the rapid changes in features and supported communications rates. In many cases, no new hardware is required. Contact your modem supplier for details.

Back to Contents Page


ABT: Motorola ML3054 Software Modem User's Guide

Answer-Back tone.


How to Add AT Commands: Motorola SM56 Software Modem User's Guide

1. Open the Control Panel.

2. Double-click the Modem icon.

3. Select the Motorola SM56 modem.

4. Click on Properties.

5. Select Connection.

6. Click on the Advanced tab.

7. In the Extra Settings box, add commands as needed. The AT prefix is not required, although the Extra Settings box will accept it.


Application Compatibility: Motorola SM56 Software Modem User's Guide

The modem supports communications applications that run:

• Under Windows 98 or Windows Millenium or Windows XP

• Under Windows 2000 and Windows NT 4.0

• In the Windows 98 DOS box


+++ (Plus-Plus-Plus) Commands: Motorola SM56 Software Modem User's Guide

This command, known as the escape sequence, causes the modem to stop transmitting data (if it is doing so), and go into command mode.

Issue this command at the computer keyboard, in the communications application's terminal window, by typing the plus sign (+) three times.

NOTE: Do not press the ENTER key after the +++ command. It may cancel the command.


AT and AT& (Ampersand) Commands: Motorola SM56 Software Modem User's Guide

Back to Contents Page

AT and AT& (Ampersand): Motorola SM56 Software Modem User's Guide

The modem responds to the following AT and AT& command options.

The letters AT (or at) must precede all commands except A/ and +++. Factory-default options are underlined.

Command Option Description

A

(none)

Answer incoming call

A/

(none)

Repeat Last Command

Re-issues the previous command to the modem.

(Do not press Return; the command executes as soon as the / is pressed.)

D

(none)

Dial a Number

Instructs the modem to dial the telephone number that you enter immediately after the ATD command. Example: ATD5554678.

NOTE: If multiple ATD commands are used in speakerphone mode, the modem must be forced to blind-dial after dial-tone detection.

E

Echo Async (Keyboard) Input to Terminal

Determines whether the characters you type at the keyboard are displayed (echoed) to the terminal-emulation window (if it is active) or to the communications application.

E0

Disable

E1

Enable

H

Hook

H0

Go on Hook (disconnect from the telephone line; hang up)

H1

Go off Hook (connect to the telephone line)

I

Request Information From Modem

I0

“56000”

I1

“000”

I2

“OK”

I3

Software Version

I4

“OK”

I5

Disconnect Reason

I6

Country Code

I7

Product Code

L

Speaker Volume

This parameter determines the volume, for call-progress monitor only, of sounds such as dialing, ringing, busy, negotiation.

L0, L1

Low

L2

Medium

L3

High

M

Speaker Control

M0

Off

M1

On During Training Only

M2

Always On

M3

Off during dialing; on during call progress; off during data transfer

O

Return to On-Line Mode

This parameter determines whether the modem initiates a retrain after changing from escape mode to data mode, or after a semi-colon in dial strings.

O0

No Retrain

O1

Retrain

O2

Initiate Rate Renegotiation

O3

Rate Renegotiation with silence

P

P

Pulse Dial

Q

Result-Code Display

The modem can send result codes and connect messages to the computer as a result of connecting or failing to connect; establishing a data rate; and establishing error-correction and data-compression protocols. Refer to: ATV; AT\V; ATX.

Q0

Enable display

Q1

Disable display

T

T

Tone Dial

This command instructs the modem to use DTMF tone dialing.

V

Result-Code Format

Determines whether the modem sends short- or long-form messages to the communications application, indicating the connection status, rate, and mode.

V0

Return Numeric Code (Short Form)

V1

Return Text (Long Form)

X

Select Call-Progress Result Codes to Return

X0

No Carrier; Connect. Modem reports lack of a carrier signal; connection success/failure; modem dials without waiting for a dial tone

X1

No Carrier; Connect; Connect <rate>. Modem reports lack of a carrier signal; connection success/failure, and the computer data rate established

X2

No Carrier; Connect; Connect <rate>; No Dial Tone. Modem reports lack of a carrier signal; connection success/failure; the computer data rate established; and the lack of a dial tone

X3

No Carrier; Connect; Connect <rate>; Busy-tone. Modem reports lack of a carrier signal; connection success/failure; the computer data rate established; and the presence of a busy signal

X4

No Carrier; Connect; Connect <rate>; No Dial-tone; Busy-tone. Modem reports lack of a carrier signal; connection success/failure; the computer data rate established; the lack of a dial tone; and the presence of a busy signal

Z

Z

Reset Modem Parameters to Default Configuration

&C

DCD Control

&C0

Always Asserted

&C1

Asserted in Data Mode Only

&D

DTR Control

Determines how modem responds to DTR signal from DTE.

&D0

Ignore DTR

&D1

Enter Command mode when DTR transitions from asserted to de-asserted

&D2

Disconnect call when DTR transitions from asserted to de-asserted

&D3

Reset modem parameters to default configuration when DTR transitions from asserted-to-de-asserted

&F

Initialize modem to default factory configuration.

&G

Guard Tone

&G0

Off

&G1

550 Hz Guard Tone

&G2

1800 Hz Guard Tone

&I

Dial TX Level

&In

Level n; n = 0 to 15. Default = 9

&I99

Automatic Level

&P

Pulse Cycle

Used when the modem is instructed to pulse dial.

&P0

40/60 Make/Break Ratio

&P1

33/67 Make/Break Ratio

&P2

38/62 Make/Break Ratio

&R

CTS Control

&R0

Normal

&R1

Always On

&S

DSR Control

&S0

Always On

&S1

On When Modem Recognizes Remote

&T

Test

&T0

Terminate Test

&T1

Initiate Local Analog Loopback Test

Disconnect the telephone line from the modem line input connector before using this command.

Set S-Register 46 = 23 (ATS46=23) before executing &T1.

&V

Modem Status

&V0

Short Form Report

&V1

Current or Last Connection Report

&V2

Long Form Report

Table 1: AT and AT& Commands


AT* (Asterisk) Commands: Motorola SM56 Software Modem User's Guide

The modem responds to the following AT* command options.

The letters AT (or at) must precede all commands except A/ and +++. Factory-default options are underlined.

Command | Option | Description
*DD |  | Dial Wait The modem will wait for dial tone before dialing the digits following "W". If dial tone is not detected within the time specified by AT*DDn, the modem will abort the rest of the sequence, return on-hook, and generate an error message.
 | *DD0 | 2 Seconds
 | *DD1 | 3 Seconds
 | *DD2 | 4 Seconds
 | *DD3 | 5 Seconds
 | *DD4 | 12 Seconds
 | *DD5 | 15 Seconds
 | *DD6 | 20 Seconds
 | *DD7 | 30 Seconds
 | *DD8 | 40 Seconds
*LS |  | Low-Speed Operation Protocol Lets you select a communications protocol to communicate with very low-speed or older modems.
 | *LS0 | Bell 103
 | *LS1 | ITU-T V.21 (international standard)
 | *LS2 | Bell 103 or ITU-T V.21 (Auto determination)
*MM |  | Modulation Mode
 | *MM0 | V.34 Auto Modulation
 | *MM1 | V.21
 | *MM2 | Bell 103
 | *MM4 | V.22/Bell 212
 | *MM5 | V.22bis
 | *MM6 | V.23
 | *MM10 | V.32 Only
 | *MM11 | V.32 bis
 | *MM12 | V.34 Only
 | *MM13 | K56flex™ Only
 | *MM14 | K56flex™ Auto-modulation
 | *MM15 | V.90 Only
 | *MM16 | V.90 Auto
 | *MM17 | V.92 Only
 | *MM18 | V.92 Auto

Table 1: AT* (Asterisk) Commands


AT Commands - Basics: Motorola SM56 Software Modem User's Guide

Attention (AT) commands are the means by which you control and monitor a modem. Typically, the communications application automatically issues them, and you need not know the commands and their options.

However, to custom-configure the modem for an application, or to optimize performance, you can issue commands through the communications application yourself. In most communications applications, there is a menu item, or option, for entering extended or custom AT commands. See your communications application documentation.

You can also configure the modem by issuing AT commands directly from a simple terminal-emulation application. One such application is HyperTerminal, which is present on computers that have Windows.

To issue an AT command from the terminal-emulation application, you must ensure that the modem is in command mode (in which it can detect and respond to commands), rather than data mode (in which it is transmitting and receiving data). To enter command mode from data mode, enter +++. You need not press the ENTER key.

When entering AT commands, the following basic rules apply:

• AT commands can be entered in uppercase, lowercase, or mixed text

• The characters AT begin all AT commands, except A/ and +++

• The key used as the ENTER key is specified in S-Register S3

• The maximum command length is 64 characters.

You can enter more than one AT command on a line, and you can chain commands using just one “AT” at the start. However, some commands must occur at the beginning or end of the command line.


AT% (Percent) and AT\ (Backslash) Commands: Motorola SM56 Software Modem User's Guide

Back to Contents Page

AT% (Percent) and AT\ (Backslash) Commands : Motorola SM56 Software Modem User's Guide

The modem responds to the following AT% and AT\ command options.

The letters AT (or at) must precede all commands except A/ and +++. Factory-default options are underlined.

Command | Option | Description
%B |  | Maximum Modulation Rate Sets the maximum rate that the modem uses when connecting in a data modulation mode for performing functions such as Internet access or file transfer
 | %B0 | Maximum modem rate that the modem supports
 | %B1 | 300 bps
 | %B2 | 1.2 Kbps
 | %B3 | 2.4 Kbps
 | %B4 | 4.8 Kbps
 | %B6 | 9.6 Kbps
 | %B7 | 7.2 Kbps
 | %B8 | 12.0 Kbps
 | %B9 | 14.4 Kbps
 | %B11 | 16.8 Kbps
 | %B12 | 19.2 Kbps
 | %B13 | 21.6 Kbps
 | %B14 | 24.0 Kbps
 | %B15 | 26.4 Kbps
 | %B16 | 28.8 Kbps
 | %B17 | 31.2 Kbps
 | %B18 | 33.6 Kbps
 | %B19 | 32.0 Kbps
 | %B20 | 34.0 Kbps
 | %B21 | 36.0 Kbps
 | %B22 | 38.0 Kbps
 | %B23 | 40.0 Kbps
 | %B24 | 42.0 Kbps
 | %B25 | 44.0 Kbps
 | %B26 | 46.0 Kbps
 | %B27 | 48.0 Kbps
 | %B28 | 50.0 Kbps
 | %B29 | 52.0 Kbps
 | %B30 | 54.0 Kbps
 | %B31 | 56.0 Kbps
 | %B32 | 58.0 Kbps
 | %B33 | 60.0 Kbps
 | %B34 | 28000 bps
 | %B35 | 29333 bps
 | %B36 | 30666 bps
 | %B37 | 33333 bps
 | %B38 | 34666 bps
 | %B39 | 37333 bps
 | %B40 | 38666 bps
 | %B41 | 41333 bps
 | %B42 | 42666 bps
 | %B43 | 45333 bps
 | %B44 | 46666 bps
 | %B45 | 49333 bps
 | %B46 | 50666 bps
 | %B47 | 53333 bps
 | %B48 | 54666 bps
%C |  | Data Compression (DC) Mode Determines whether the modem implements methods of increasing the effective data rate by reducing the number of bits used to represent data
 | %C0 | Disable Compression
 | %C1 | Enable Compression
%D |  | Disconnect Buffer Delay Controls the delay after detection of a disconnect request before the modem disconnects from the telephone line. During the delay Tx buffer state is checked, if Tx buffer get empty, the modem immediately disconnects
 | %D0 | Disable Delay
 | %Dn | Delay for n Seconds (n = 1 to 255)
%L |  | Minimum Modulation Rate Sets the minimum rate that the modem uses when connecting in a data modulation mode.
 | %L0 | Minimum modem rate that the modem supports(300 bps)
 | %L1 | 300 bps
 | %L2 | 1.2 Kbps
 | %L3 | 2.4 Kbps
 | %L4 | 4.8 Kbps
 | %L7 | 7.2 Kbps
 | %L6 | 9.6 Kbps
 | %L8 | 12.0 Kbps
 | %L9 | 14.4 Kbps
 | %L11 | 16.8 Kbps
 | %L12 | 19.2 Kbps
 | %L13 | 21.6 Kbps
 | %L14 | 24.0 Kbps
 | %L15 | 26.4 Kbps
 | %L16 | 28.8 Kbps
 | %L17 | 31.2 Kbps
 | %L18 | 33.6 Kbps
 | %L19 | 32.0 Kbps
 | %L20 | 34.0 Kbps
 | %L21 | 36.0 Kbps
 | %L22 | 38.0 Kbps
 | %L23 | 40.0 Kbps
 | %L24 | 42.0 Kbps
 | %L25 | 44.0 Kbps
 | %L26 | 46.0 Kbps
 | %L27 | 48.0 Kbps
 | %L28 | 50.0 Kbps
 | %L29 | 52.0 Kbps
 | %L30 | 54.0 Kbps
 | %L31 | 56.0 Kbps
 | %L32 | 58.0 Kbps
 | %L33 | 60.0 Kbps
 | %L34 | 28000 bps
 | %L35 | 29333 bps
 | %L36 | 30666 bps
 | %L37 | 33333 bps
 | %L38 | 34666 bps
 | %L39 | 37333 bps
 | %L40 | 38666 bps
 | %L41 | 41333 bps
 | %L42 | 42666 bps
 | %L43 | 45333 bps
 | %L44 | 46666 bps
 | %L45 | 49333 bps
 | %L46 | 50666 bps
 | %L47 | 53333 bps
 | %L48 | 54666 bps
\K |  | Break Handling Method
 | \K1 | Destructive Expedited
 | \K3 | Non-destructive Expedited
 | \K5 | Non-destructive Non-expedited
\N |  | Error-Correction (EC) Mode
 | \N0 | Normal
 | \N1 | Direct
 | \N4 | LAP-M Only
 | \N6 | Reliable
 | \N7 | Auto-Reliable
\Q |  | DTE Flow Control
 | \Q0 | Disable
 | \Q1 | XON/XOFF (software flow control)
 | \Q3 | RTS/CTS (hardware flow control)
\T |  | Disconnect on DTE Inactivity
 | \T0 | Disable
 | \Tn | Disconnect after n minutes of inactivity by the computer; n = 0 to 255
\V |  | Connect Message Format Determines which messages the modem generates at connection time
 | \V0 | Display DTE Rate
 | \V1 | DTE with EC /DC message
 | \V2 | Display DCE Rate
 | \V3 | DCE with EC/DC Message
 | \V4 | DCE with Modulation & EC/DC Message

Table 1: AT% (Percent) and AT\ (Backslash) Commands


AT+ (Plus) Commands: Motorola SM56 Software Modem User's Guide

The modem responds to the following AT+ command options.The letters AT (or at) must precede all commands except A/ and +++.

Factory-default options are underlined.

AT commands that begin with:

+D control data compression

+F control fax application operation

These commands are primarily used by software applications.

Command | Option | Description
+A8E |  | V.8 Configuration
 | +A8E=a,b,c,d |
 | a options: | Specifies V.8 origination negotiation options
 | 0 | Disable
 | 1 | Enable computer-controlled V.8 origination negotiation
 | 6 | Enable computer-controlled V.8 origination negotiation with +A8x indications
 | b options: | Specifies V.8 answer negotiation options
 | 0 | Disable
 | 1 | Enable computer-controlled V.8 answer negotiation
 | 5 | Enable computer-controlled V.8 answer negotiation with +A8x indications
 | c options: | Specifies the V.8 CI Signal Call Function Octet options
 | 00h - FFh, default=00h |
 | d options: | Specifies V.8 control options
 | 0 | Disabled
 | 1 | Enabled, modem control
 | 2 | Enabled, computer control
+A8T |  | V.8bis Signal and Message Control
 | +A8T=a,b,c,d,e,f |
 | a options: | Specifies V.8bis Signal to Transmit
 | 0 | None
 | 1 | Initiating MRe
 | 2 | Initiating MRd
 | 3 | Initiating Cre, low power
 | 4 | Initiating Cre, high power
 | 5 | Initiating Crd
 | 6 | Initiating Esi
 | 7 | Responding MRd, low power
 | 8 | Responding MRd, high power
 | 9 | Responding CRd
 | 10 | Responding ESr
 | b options: | Specifies V.8bis Transmit Message 1
 |  | hexadecimal octet coded string
 | c options: | Specifies V.8bis Transmit Message 2
 |  | hexadecimal octet coded string
 | d options: | Specifies V.8bis signal detection
 | 0 | Enable detection of initiating V.8bis signal
 | 1 | Enable detection of responding V.8bis signal
 | 2 | Enable detection of both V.8bis signals
 | e options: | Specifies V.8bis message detection
 | 0 | Disable detection
 | 1 | Enable detection
 | f options: | Specifies the V.8bis message delay
 | 0 | No delay between transmitting signal and messages
 | 1 | 1.5 second delay between transmitting signal and any message
+DR |  | Data Compression (DC) Reporting
 | +DR=0 | Disabled
 | +DR=1 | Enabled
+DS |  | Data Compression Control
 | +DS=p,q,r,s |
 | p options: | Specifies compression on/off direction
 | 0 | No compression
 | 1 | Tx direction only
 | 2 | Rx direction only
 | 3 | Both directions; accept any direction
 | q options: | Specifies negotiation
 | 0 | Do not disconnect if data compression is not negotiated per Direction option
 | 1 | Disconnect if data compression is not negotiated per Direction option
 | r options: | Specifies maximum dictionary size
 | 512 - 8192 | Default = 2048
 | s options: | Specifies maximum string size
 | 6 - 250 | Default = 32
+EB |  | Break Handling Control
 | +EB=p,q r |
 | p options: | Specifies break selection
 | 0 | Ignore break
 | 1 | Non-expedited, non-destructive
 | 2 | Expedited, non-destructive
 | 3 | Expedited, destructive
 | q options: | Specifies break length control
 | 0 | Transmission of V.42 L-SIGNAL does not indicate break length
 | 1 | Transmission of V.42 L-SIGNAL indicates break length
 | r options: | Specifies the default break-length
 | 0 | Break is not transmitted to the computer
 | 1- 254, default=100 | Break length, in 0.01-second increments
+ER |  | Error-Control Reporting
 | +ER=a |
 | a options: | Specifies the modem’s error-control reporting activity
 | 0 | Disabled
 | 1 | Enabled: modem issues one of the following messages to the computer, before it issues a connect message. The message specifies the Error Correction protocol negotiated: +ER:NONE +ER:LAPM +ER:ALT
+ES |  | Error-Correction (EC) Control
 | +ES=p,q r |
 | p options: | Specifies the originate-modem’s Request Error Correction mode
 | 0 | Direct mode
 | 1 | Normal mode
 | 2 | LAP-M Only
 | 3 | LAP-M or MNP
 | 4 | MNP Only
 | 6 | Initiate Sync Access mode when connection is established
 | q options: | Specifies the answer-modem’s Fallback Error Correction mode
 | 0 | EC optional, fallback to Normal mode
 | 1 | EC optional, fallback to Direct mode
 | 2 | EC required (LAP-M or MNP)
 | 3 | EC required (LAP-M only)
 | 4 | EC required (MNP only)
 | r options: | Specifies the originate-modem’s Fallback Error Correction mode
 | 0 | Direct mode
 | 1 | Normal mode
 | 2 | EC optional, fallback to Normal mode
 | 3 | EC optional, fallback to Direct mode
 | 4 | EC required (LAP-M or MNP)
 | 5 | EC required (LAP-M only)
 | 6 | EC required (MNP only)
 | 8 | Initiate synchronous access mode when connected
+ESA |  | Synchronous Access Mode Configuration
 | +ESA=a,b,c,d,e,f |
 | a options: | Specifies the Idle in Transparent sub-mode
 | 0 | Computer transmits 8 bit SYN sequence on idle. Computer does not hunt for synchronization sequence
 | b options: | Specifies the Idle in Framed sub-mode
 | 0 | Computer transmits HDLC flags on idle
 | c options: | Specifies under-run and over-run in Framed sub-mode
 | 0 | Computer transmits Abort on an under-run within a frame
 | 1 | Computer transmits a Flag on an under-run within a frame, and notifies the modem of any under-run or over-run
 | d options | Specifies half-duplex control. Not available.
 | e options | Specifies the Cyclic Response Code (CRC) type
 | 0 | Disabled. No CRC generation or checking.
 | 1 | In Framed sub-mode, the computer generates 16-bit CRC in the Transmit direction and the modem generates 16-bit CRC on the Receive direction.
 | f options: | Specifies Non-Return to Zero (NRZI) options
 | 0 | NRZI encoding and decoding are disabled.
+ETBM |  | Disconnect Buffer Delay Control
 | +ETBM=p,q r |
 | p options: | Specifies the disconnect buffer delay with pending transmit data
 | 0 | Discard buffered data and disconnect
 | 1 | Attempt to transmit until all data is delivered, then disconnect. Ignore timer.
 | 2 | Attempt to transmit until all data is delivered or timer expires.
 | q options: | Specifies the disconnect buffer delay with pending receive data
 | 0 | Discard buffered data and disconnect
 | 1 | Attempt to transmit until all data is delivered, then disconnect. Ignore timer.
 | 2 | Attempt to transmit until all data is delivered or timer expires.
 | r options: 1-255, default=0 | Disconnect buffer delay timer, in 1-second increments
+FCLASS |  | Fax/Data Mode
 | +FCLASS=0 | Data Mode
 | +FCLASS=1 | Fax Class 1
 | +FCLASS=8 | Voice Mode (Not available in Data/Fax and Data/Fax/TAM modems.)
+FLO |  | Fax Flow Control
 | +FLO=0 | None
 | +FLO=1 | XON/XOFF
 | +FLO=2 | RTS/CTS
+FMI? |  | Report Manufacturer ID
+FMM? |  | Report Modem ID
+FMR? |  | Report Software Version
+FRH |  | Receive High-Level Data Link Control (HDLC) Mode Sets mode and transmit/receive rate for faxes
 | +FRH=3 | V.21 at 300 bps
 | +FRH=24 | V.27ter at 2.4 Kbps
 | +FRH=48 | V.27ter at 4.8 Kbps
 | +FRH=72 | V.27ter at 7.2 Kbps
 | +FRH=73 | V.27ter at 7.2 Kbps with long train time
 | +FRH=74 | V.27ter at 7.2 Kbps with short train time
 | +FRH=96 | V.29 at 9.6 Kbps
 | +FRH=97 | V.17 at 9.6 Kbps with long train time
 | +FRH=98 | V.17 at 9.6 Kbps with short train time
 | +FRH=121 | V.17 at 12.0 Kbps with long train time
 | +FRH=122 | V.17 at 12.0 Kbps with short train time
 | +FRH=145 | V.17 at 14.4 Kbps with long train time
 | +FRH=146 | V.17 at 14.4 Kbps with short train time
+FRM | +FRM | Receive Mode Sets the modulation mode for receiving faxes
 | +FRMm | Use mode m; see mode options for +FRH, above.
+FRS |  | Wait for Silence
 | +FRSn | Wait (n*10) ms; n=0 to 255
+FTH | +FTH | Transmit High-Level Data Link Control (HDLC) Mode
 | +FTHmode | Use mode mode; see options for +FRH, above.
+FTM | +FTM | Transmit Mode Sets the modulation mode for transmitting faxes
 | +FTMmode | Use mode mode; see options for +FRH, above.
+FTS |  | Pause Transmission
 | +FTSn | Pause transmission for (n*10) ms; n=0 to 255
+GCAP |  | Report Capabilities
 | +GCAP | Display modem capabilities
+GCI |  | Country of Installation
 | +GCI=a | Set country in which modem is installed
 | 00 | Japan
 | 04 | Germany
 | 07 | Argentina
 | 09 | Australia
 | 0A | Austria
 | 0F | Belgium
 | 16 | Brazil
 | 1B | Bulgaria
 | 20 | Canada
 | 25 | Chile
 | 26 | China
 | 27 | Columbia
 | 2E | Czech Republic
 | 2D | Cyprus
 | 31 | Denmark
 | 3C | Finland
 | 3D | France
 | 42 | Germany
 | 50 | Hong Kong
 | 57 | Ireland
 | 58 | Israel
 | 59 | Italy
 | 5E | Jordan
 | 61 | Korea
 | 68 | Liechtenstein
 | 6C | Malaysia
 | 70 | Malta
 | 7B | Netherlands
 | 82 | Norway
 | 8B | Portugal
 | 8C | Puerto Rico
 | 9C | Singapore
 | 9F | South Africa
 | A0 | Spain
 | A5 | Sweden
 | A6 | Switzerland
 | A9 | Thailand
 | AE | Turkey
 | B4 | United Kingdom
 | B5 | USA
 | BB | Venezuela
 | BC | Vietnam
+GMI |  | Request Manufacturer ID
 | +GMI? | Display modem-manufacturer information
+GMM |  | Request Model ID
 | +GMM? | Display modem-model information
+GMR |  | Request Software Version
 | +GMR? | Display modem-software version
+IFC |  | Flow Control
 | +IFC=p,q |
 | p options: | Specifies the computer’s flow control method for data passing to the modem (downstream)
 | 0 | None
 | 1 | XON/XOFF flow control, no pass-through
 | 2 | RTS flow control
 | 3 | XON/XOFF flow control, with pass-through
 | q options: | Specifies the modem’s flow control method for data passing from the modem (upstream)
 | 0 | None
 | 1 | XON/XOFF flow control, no pass-through
 | 2 | CTS flow control
+ILRR |  | Computer’s Local Rate Reporting
 | +ILRR=0 | Disabled
 | +ILRR=1 | Enabled
+ITF |  | Transmit Flow Control Thresholds (V.80)
 | +ITF=a,b |
 | a options: | Specifies the threshold, in octets, at which the modem turns transmit flow-control off
 | 0-2047 default=255 |
 | b options: | Specifies the threshold, in octets, at which the modem turns transmit flow-control on
 | 1-2047 default=255 |
+MR |  | Modulation Mode Reporting
 | +MR=0 | Disabled
 | +MR=1 | Enabled
+MS |  | Modulation Control
 | +MS=p,q,r,s,t,u |
 | p options: | Specifies the modulation mode
 | V21 | V.21
 | V22 | V.22
 | V22B | V.22bis
 | V23C | V.23c
 | V32 | V.32
 | V32B | V.32bis
 | V34 | V.34
 | K56FLEX | K56flex™
 | V90 | V.90
 | V92 | V.92
 | q options: | Specifies the Automode option
 | 0 | Disabled
 | 1 | Enabled
 | r options: | Specifies the minimum data rate in the Tx direction
 | 0 | Use the minimum rate of the specified modulation mode (300 bps)
 | 300 - 33600 | bps
 | s options: | Specifies the maximum data rate in the Tx direction
 | 0 | Use the maximum rate of the specified modulation mode
 | 300 - 33600 | bps
 | t options: | Specifies the minimum data rate in the Rx direction
 | 0 | Use the minimum rate of the specified modulation mode
 | 300 - 60000 | bps
 | u options: | Specifies the maximum data rate in the Rx direction
 | 0 | Use the maximum rate of the specified modulation mode
 | 300 - 60000 | bps
+VCID |  | Caller ID Control
 |  | This option takes effect only where the function is supported. Data/Fax modems do not support this option.
 | +VCID=0 | Disable
 | +VCID=1 | Enable
 | +VCID=? | Display Caller ID Status (returns 0 or 1)
+VDR |  | Distinctive Ring Control and Report
 |  | This option takes effect only where the function is supported. Data/Fax modems do not support this option
 | +VDR=m,n | NOTE: If Distinctive Ring is enabled, the first ring reported by the modem may be incorrect.
 | m options: | Specifies control
 | 0 | Disable
 | 1 | Enable
 | n options: | Specifies reporting
 | 0 | Produce DROFF/DRON report, no RING
 | 1-255 | Produce DROFF/DRON, followed by RING after delay of n/10 seconds
+VEM |  | Event Reporting and Masking Control
Data/Fax/Speakerphone modem only
 | +VEM=m | Bit-mapped event control mask. See Event Reporting Word.
+VGR |  | Receive Gain
Data/Fax/Speakerphone modem only
 | 0 | Automatic Gain Control
 | 1-255 | Relative range, where 128 indicates a nominal value.
+VGT |  | Transmit Volume
Data/Fax/Speakerphone modem only
 | 1-255 | Relative range, where 128 indicates a nominal value.
+VIP |  | Initialize Voice Parameters
Data/Fax/Speakerphone modem only
 |  | Set speakerphone parameters to factory-default options.
+VLS |  | Select Analog Source and Destination
Data/Fax/Speakerphone modem only
 | 0 | DCE (modem) on-hook
 | 1 | DCE off-hook, DCE connected to telco
 | 8 | DCE on-hook, DCE connected to speaker
 | 9 | speakerphone with mute enabled
 | 11 | DCE on-hook, DCE connected to microphone
 | 13 | DCE off-hook, DCE connected to telco, speaker, and microphone (speakerphone)
+VNH |  | Automatic Hangup Control
Data/Fax/Speakerphone modem only
 | +VNH=0 | Retain automatic hang-ups
 | +VNH=1 | Disable DCE-initiated automatic hang-ups
 | +VNH=2 | Disable all Automatic hang-ups
+VPR |  | Voice DTE-DCE Rate
Data/Fax/Speakerphone modem only
 | +VPR=0 | Autobaud
+VRA |  | Ringback Gone Timer
Data/Fax/Speakerphone modem only
 |  | If, after detecting ringback, no further ringbacks are detected after n/10 seconds, operate as if the remote device answered the call.
 | +VRA=n | If no ringback is received, after n/10 seconds, assume that the remote device has answered the call; n = 0-255
 |  | Ringback Never Occurred
 | +VRN=n | After n/10 seconds, operate as if ringback never occurred; n = 0-255
+VRX |  | Voice Receive Mode
Data/Fax/Speakerphone modem only
 |  | Determines whether the modem generates a periodic beep, audible to both parties on the speakerphone, indicating that the call is being recorded.
 |  | NOTES: The speakerphone state does not have to be reset after recording to the line or playing a message to the line. The baud rate is not set before the StartPlay and StartRecord commands. The baud rate is not reset after the StopPlay and StopRecord commands.
 | +VRX or +VRX=0 | Produce Periodic DCE Tone While Recording
 | +VRX=1 | Disable Periodic DCE Tone Production During Recording
+VSD |  | Remote Silence-Detection Properties
Data/Fax/Speakerphone modem only
 | +VSD=m,n | Used in answering-machine mode. Specifies the volume and duration thresholds that determine whether the remote device has hung up.
 | m options: | Specifies the silence-detection level
 | 0 | Use current +VSM value; or, if current +VSM value is 0, use 128.
 | 127 | Low Threshold (most sensitive)
 | 128 | Medium Threshold
 | 129 | High Threshold (least sensitive)
 | n options: | Specifies the silence-detection duration
 | 0 | Disable
 | 1-255 | Detect n/10 secnds silence; n = 0-255
 | 60 | Default = 6 seconds
+VSM |  | Speech Compression Properties
Data/Fax/Speakerphone modem only
 | +VSM=m,n,p,q | Specifies the speakerphone compression parameters
 | m options: | Specifies the compression method
 | 128 | PCM
 | 129 | ADPCM
 | n options: | Specifies the sampling rate to determine whether to compress
 | 8000 | 8000 Hz
 | p options: | Parameter p specifies compression and expansion of periods of silence. These parameters are not implemented in Release 1.0. You may leave them blank or enter the value 0.
 | 0 | Disable
 | q options: | Parameter q specifies compression and expansion of periods of silence. These parameters are not implemented in Release 1.0. You may leave them blank or enter the value 0.
 | 0 | Disable
+VTD |  | Dual Tone Multi-Frequency (DTMF) Tone Duration
Data/Fax/Speakerphone modem only
 | +VTDn | Generates tone for n/100 seconds; n = 0-255. Default=100.
+VTS |  | DTMF Tone Generation Properties
Data/Fax/Speakerphone modem only
 |  | +VTS accepts multiple options, separated by commas, of any of the following types. Use square or curly brackets as shown.
 | D | Generate default DTMF Tone, default duration.
 | {t,n} | t specifies a DTMF tone; t = 0-9 n specifies tone duration n/100 seconds; n = 1-500
 | {f,g,n} | f and g specify a tone pair, f Hz and g Hz; in the range n Specifies tone-pair duration n/100 seconds; n = 1-500
 | Example: | AT+VTS=4,{},[1000,1300,50],8,{*,5},[,,100],5 This example specifies the following sequence: 1. Play DTMF 4 for the duration stored in +VTD 2. Play silence for the duration stored in +VTD 3. Play tone pair at 1000 Hz and 1300 Hz for 500 ms 4. Play DTMF 8 for a duration stored in +VTD 5. Play DTMF * for 50 ms 6. Play silence for 1 second 7. Play DTMF 5 for the duration stored in +VTD
+VTX |  | Enter Voice-Transmission Mode
Data/Fax/Speakerphone modem only
 |  | NOTES: The speakerphone state does not have to be reset after recording to the line or playing a message to the line. The baud rate is not set before the StartPlay and StartRecord commands. The baud rate is not reset after the StopPlay and StopRecord commands.


ATH: Motorola SM56 Software Modem User's Guide

Attention Hang-up signal. Directs the modem to go on-hook.


ATS (S-Register) Commands: Motorola SM56 Software Modem User's Guide

The modem responds to the following ATS command options.

The letters AT (or at) must precede all commands except A/ and +++. Factory-default options are underlined.

S-Register | Option | Description
S0 |  | Auto-Answer on Ring Number
 | S0=0 | Disable
 | S0=n | Answer on Ring n; n=0 to 255
S1 |  | Ring Count
 | S1=n | Counts the number of rings in an incoming call. If the modem is configured to auto-answer (S0 set to a non-zero option), when S1=S0, the modem answers the call.
S2 |  | Select Escape Character
 | S2=n | Specifies ASCII character for Escape; n=0 to 255. Default = 43 (+)
S3 |  | Select Carriage-Return Character
 | S3=n | Specifies ASCII character for Carriage-Return; n=0 to 127. Default = 13 (CR)
S4 |  | Select Line-Feed Character
 | S4=n | Specifies ASCII character for Line-Feed; n=0 to 127. Default = 10 (LF)
S5 |  | Select Backspace Character
 | S5=n | Specifies ASCII Character for Backspace; n=0 to 127. Default = 8 (BS)
S6 |  | Blind Dial
 | S6=n | Before dialing, the modem goes off-hook and waits n seconds; n=0 to 255. Note: When the ATX2 or ATX4 option is in effect, the S6 value is disregarded. Default = 2
S7 |  | Call Time-out
 | S7=n | Number of seconds in which connection must be established or call will be disconnected; n=1 to 255. Default = 60
S8 |  | Pause Delay
 | S8=n | Pause for n seconds; n=0 to 255; for dial modifier in a dial string. Default = 2
S10 |  | DCD Loss Disconnect
 | S10=n | Disconnect after n seconds; n=0 to 255 in 0.1 second increments (the interval may vary depending on country settings. For example: for USA n=3 to 255, for Germany n=3, 7, 255); after DCD signal is de-asserted. Default = 14
S11 |  | Tone Length
 | S11=n | Specifies duration, in 0.001 second increments, of DTMF tone when it is generated; n=60 to 255. Default =72
S12 |  | Escape Code Guard Time
 | S12=n | Specifies the interval, in 0.02-second increments, that must be present on either side of the escape code (+++) for the modem to recognize the escape command and enter command mode. If S12=0, the speed at which you enter the escape sequence is not a factor. Default = 50
S18 |  | Test Timer
 | S18=n | Specifies test execution duration; n=0 to 255. Default = 0

Table 1: ATS (S-Register) Commands


AT#UD Unimodem Diagnostic Command: Motorola SM56 Software Modem User's Guide

The Unimodem Diagnostic Command Specification is provided by Microsoft to enable modems to exhibit consistent behavior during data session diagnostics. The latest specification revision of this command can be found on the Microsoft Web site.

Command Syntax:

AT#UD

#UD is an action command. It does not take parameters.

Although this command is intended for use after call termination, codes are defined so that a modem can respond before the call is placed, and during a call for live monitoring purposes.

Command Response:

In response to this command, the modem reports information about the modem. Each information text line is formatted as follows, including one or more key=value pairs:

DIAG <token key = value [[key = value] [key = value]] …>

Where, token is a unique 32-bit hex number 2A4D3263

key is a hex number, described in column 1 of Table 1.

value is a string defined by column 2 in Table 1.

NOTE: Unless otherwise noted, all values are hexadecimal numbers.

Key | Value | Definition
0 | 2 digits | Diagnostic Command Specification revision number
1 | See Table 2 | Call Setup Result code
2 | See Table 3 | Multi-media mode
3 | See Table 4 | DTE-DCE interface mode
4 | String | V.8 CM octet string, same format as V.25ter Annex A, in quotes
5 | String | V.8 JM octet string, same format as V.25ter Annex A, in quotes
6F |  | Reserved for call negotiation reports
10 | 0-2F | Received signal power level, in –dBm (0-43)
11 | 0-1F | Transmit signal power level, in –dBm (e.g. 0-17)
12 | 0-64 | Estimated noise level, in –dBm (e.g. 10-90)
13 | 0-FF | Normalized Mean Squared error, 100 (0x64) = minimum inter-symbol distance
14 | 0-3F | Near echo loss, in units of dB
15 | 0-3F | Far echo loss, in units of dB
16 | 0-3F | Far echo delay, in units of ms
17 | 0-FFF | Round Trip delay, in units of ms
18 | See Table 5 | V.34 INFO bit map
19-1F |  | Reserved for modulation setup and training reports
20 | See Table 6 | Transmit Carrier Negotiation Result
21 | See Table 6 | Receive Carrier Negotiation Result
22 | 0-1F40 | Transmit Carrier symbol rate (0-8000) in symbol/s
23 | 0-1F40 | Receive Carrier symbol rate (0-8000) in symbol/s
24 | 0-FA0 | Transmit Carrier frequency (0-4000) in Hz
25 | 0-FA0 | Receive Carrier frequency (0-4000) in Hz
26 | 0-FA00 | Initial transmit carrier data rate (0-64000) in bit/s
27 | 0-FA00 | Initial receive carrier data rate (0-64000) in bit/s
28-2F |  | Reserved
30 | 0-FF | Temporary carrier loss event count
31 | 0-FF | Carrier Rate re-negotiation event count
32 | 0-FF | Carrier Retrains requested
33 | 0-FF | Carrier Retrain requests granted
34 | 0-FA00 | Final transmit carrier data rate in bit/s
35 | 0-FA00 | Final receive carrier data rate in bit/s
36-3F |  | Reserved
40 | See Table 7 | Protocol Negotiation Result
41 | 0-400 | Error Control frame size in bytes
42 | 0-FF | Error control link timeouts in transmission
43 | 0-FF | Error control link NAKs received
44 | See Table 8 | Compression Negotiation Result
45 | 0-800 | Compression dictionary size in bytes
46-4F |  | Reserved
50 | 0-2 | Transmit flow control: 0 = off; 1 = DC1/DC3; 2 = V.24 ckt 106/133
51 | 0-2 | Receive flow control: 0 = off; 1 = DC1/DC3; 2 = V.24 ckt 106/133
52 | 0-FFFFFFFF | Transmit characters sent from DTE
53 | 0-FFFFFFFF | Received characters sent to DTE
54 | 0-FFFF | Transmit characters lost (data overrun errors from DTE)
55 | 0-FFFF | Received characters lost (data overrun errors to DTE)
56 | 0-FFFFFFFF | Transmit I- Frame count, if error control protocol running
57 | 0-FFFFFFFF | Received I-Frame count, if error control protocol running
58 | 0-FFFF | Transmit I-Frame error count, if error control protocol running
59 | 0-FFFF | Received I- Frame error count, if error control protocol running
5A-5F |  | Reserved
60 | See Table 9 | Termination Cause
62-7F |  | Reserved for future versions of this specification
80-FF |  | Reserved for manufacturer proprietary keys

Table 1 - AT#UD Last Call Status Report Format

Code | Definition
0 | No previous call (modem log has been cleared since any previous calls)
1 | No dial tone detected
2 | Reorder signal detected, network busy
3 | Busy signal detected
4 | No recognized signal detected (e.g. no signal, or nothing recognizable)
5 | Voice detected * if this is a voice modem (e.g. V.253) operating in voice mode (e.g. +FCLASS=8.0)
6 | Text telephone signal detected (see V.18)
7 | Data Answering signal detected (e.g. V.25 ANS, V.8 ANSam)
8 | Data Calling signal detected (e.g. V.25 CT, V.8 CI)
9 | Fax Answering signal detected (e.g. T.30 CED, DIS)
A | Fax Calling signal detected (e.g. T.30 CNG)
B | V.8bis signal detected
C-F | Reserved

Table 2 - Call Setup Result Codes

Code | Definition
0 | Data Only
1 | FAX Only
2 | Voice Only * if voice mode supported (e.g. V.253, IS-101)
3 | VoiceView™
4 | ASVD, V.61
5 | ASVD, “V.34Q”
6 | DSVD, Multi-Tech
7 | DSVD, 1.2
8 | DSVD, V.70
9 | Video-telephony, H.324
A | Other V.80 call
B-F | Reserved

Table 3 – Multimedia modes

Code | Definition
0 | Async data
1 | V.80 transparent synchronous mode
2 | V.80 framed synchronous mode
3-F | Reserved

Table 4 – DTE-DCE modes

Bits | Source bits | Definition
31-30 | INFO0 bit 20; 0 |
20-29 | INFOc bits 79-88 |
16-19 | INFOc bits 26-29 or 35-38 or 44-47 or 53-56- or 62-65 or 71-74 | Pre-emphasis field, selected by the symbol rate chosen
12-15 | INFOa bits 26-29 |
10-11 | MP bit 50; 0 |
0-9 | INFOa bits 40-49 |

Table 5 – V.34 INFO bit report (applicable only to V.34 or V.90/V.92 calls)

Value | Description
0 | V.17 (G3 Fax call)
1 | V.21
2 | V.22
3 | V.22bis
4 | V.23 Constant Carrier (1200/75)
5 | V.23 Switched Carrier (half duplex)
6 | V.26bis
7 | V.26ter
8 | V.27ter (G3 Fax call)
9 | V.29 HD (G3 Fax call)
A | V.32 (difficult to distinguish from V.32bis)
B | V.32bis
C | V.34
D | V.34 HD (G3 Fax call)
E | V.90 Issue 1 (asymmetric)
F | V.90 Issue 2 (symmetric)
E-7F | Reserved (V.58)
80 | X2™
81 | K56FLEX™
82 | V.FC
83 | V.32terbo
84 | Bell 212A (if modem supports B212A)
85 | Bell 103 (if modem supports B103)
80-FF | Reserved for mfgs

Table 6 – gstnModulationSchemeActive from 3.7.2/V.58

Value | Description
0 | Disable/none
1 | V.42 LAPM
2 | V.42 Alterative protocol (MNP™)
3-7F | Reserved (V.58)
80 | MNP10™
81 | ECP™ Enhanced Cellular Protocol
82 | ETC™ Enhanced Throughput Cellular
82-FF | Reserved for mfgs

Table 7 – errorControl Active from 3.5.2/V.58

Value | Description
0 | None
1 | V.42bis
2-7F | Reserved (V.58)
80 | MNP5™
81-FF | Reserved for mfgs

Table 8 – compressionActive from 3.2.2/V.58

Indicates that the DCE has gone on hook and that the previously existing network connection has been cleared. These values are hex.

Value | Description | Notes
0 | CauseUnidentified | Call setup issues
1 | No Previous call | Not in V.58
2 | Call is still in progress | Not in V.58
3 | Call Waiting signal detected | Not in V.58, only if modem can detect it
4 | Delayed | Same as value 2A, CallAttemptsLimitExceeded
A | NMSinitiatedDialCall | -- Network Management System
B | NMSinitiatedLeasedLineRestoral |
C | NMSinitiatedRedial |
D | NMSinitiatedDialDisconnect |
14 | PowerLoss | DCE
15 | EquipmentFailure |
16 | FrontPanelDisconnectRequested | If there is a front panel with this control
17 | FrontPanelLeasedLineRestoral |
18 | AutomaticLeasedLineRestoral |
19 | InactivityTimerExpired |
1E | cct116RestoralRequest | DTE Interface
1F | cct108isOffInhibitsDial |
20 | cct108turnedOff | This is hangup with &D2
28 | NoNumberProvided | Prohibited by some national regulations
29 | BlacklistedNumber |
2A | CallAttemptsLimitExceeded | Same as “Delayed”, see ETS 300 001
2B | ExtensionPhoneOffHook | If extension detection supported
2C | CallSetupFailTimerExpired | e.g. S7 timeout
2D | IncomingCallDetected | If incoming call while sending dial command.
2E | LoopCurrentInterrupted |
2F | NoDialTone |
30 | VoiceDetected |
31 | ReorderTone |
32 | SitTone |
33 | EngagedTone |
34 | LongSpaceDisconnect | And if modem program to abort on long space
3C | CarrierLost | Signal Converter
3D | TrainingFailed |
3E | NoModulationinCommon |
3F | RetrainFailed |
40 | RetrainAttemptCountExceeded |
41 | GstnCleardownReceived |
42 | FaxDetected |
46 | InTestMode | Test
47 | IntrusiveSelfTestInitiated |
50 | AnyKeyAbort | Call Control
51 | DteHangupCommand | If ATH was used to terminate the previous call.
52 | DteResetCommand | If ATZ was used to terminate the previous call.
5A | FrameReject | Error Control
5B | NoErrorControlEstablished | Error control was required
5C | ProtocolViolation |
5D | n400exceeded |
5E | NegotiationFailed |
5F | DisconnectFrameReceived |
60 | SabmeFrameReceived |
64 | LossOfSynchronization | Data Compression

Table 9 – callCleared codes from 3.6.4/V.58-1994

Example Modem Response and Usage

Modem response lin | Description
DIAG <2A4D3263 0=10 | This is version 1.0
DIAG <2A4D3263 1=06 2=0 3=0> | Data Answer signal detected; Data only; Character async
DIAG <2A4D3263 5=”C14513902A” 6=”A145” | V.8 Call Menu indicates: V.8 Joint Menu selects:
DIAG <2A4D3263 10=1F 11=0C 12=52> | Receive level = -31dbm; transmit level = -12dbm; noise level = -82dbm
DIAG <2A4D3263 14=03 15=05 16=10> | Far end echo delay in milliseconds; Far end echo loss in dB; Near end echo loss = 16 dB
DIAG <2A4D3263 20=C 22=780 24=0C80 26=79E0 > | Transmitter: V.34 training completed; V.34 carrier frequency = 1920; V.34 symbol rate = 3200; initial transmit rate is 31200 bit/s
DIAG <2A4D3263 21=D 25=1F40 27=DAC0 > | Receiver: V.90 training completed; V.90 symbol rate = 8000; initial receive rate is 56000 bit/s
DIAG <2A4D3263 30=00 31=03 32=01 33=01> | No carrier loss events, 3 carrier rate renegotiations attempted; 1 carrier retrain requested; 1 carrier retrain granted
DIAG <2A4D3263 34=7080 35=CB20> | Final transmit rate is 28800 bit/s; final receive rate is 52000 bit/s
DIAG <2A4D3263 40=1 41=100> | LAPM negotiation completed; frame size = 256
DIAG <2A4D3263 42=0 43=0> | No error control timeout or link NAKs
DIAG <2A4D3263 44=1 45=400> | V.42bis data compression used; dictionary size = 1024
DIAG <2A4D3263 50=2 51=2> | Hardware transmit and receive flow control
DIAG <2A4D3263 52=343CC 54=0> | 213964 DTE characters transmitted, w/o underrun
DIAG <2A4D3263 53=7230E6 55=47> | 7483622 DTE characters received, 71 characters lost due to receive data overrun
DIAG <2A4D3263 56=29D 58=0001> | 597 (decimal) frames transmitted, with 1 frame error
DIAG <2A4D3263 58=2A4B 59=0004> | 10827 (decimal) frames received, with 4 frame errors
DIAG <2A4D3263 60=51> | Local PC initiated hangup

Table 10 - Completed Data Call, with some errors and rate retrain during the call


Caller ID (US and Canada only): Motorola SM56 Software Modem User's Guide

NOTE: This feature is not available on Data/Fax modems.

The modem can detect the information generated by the Caller ID service feature, which is available from many telephone companies. Check with your telephone company for details.

With Caller ID, the caller’s telephone number and the date and time of the call are transmitted over the telephone line between the first and second ring. In some areas, further data, such as the caller's name, is available with Enhanced Caller ID.

The modem transfers Caller ID data to the communications application. You may configure the application to track or process the data.

If you subscribe to Caller ID with your phone company, but it is not working, refer to the Troubleshooting section.

Beware that the caller can prevent Caller ID information from being transmitted.


CTS: Motorola SM56 Software Modem User's Guide

Clear to Send signal. The modem asserts this signal to the local computer when it is ready to receive data from the computer.

A method of transmitting data more efficiently.

Please read all restrictions and disclaimers.


DC: Motorola SM56 Software Modem User's Guide

Data-Compression


DCD: Motorola SM56 Software Modem User's Guide

Data Carrier Detect signal. The modem asserts this signal to the local computer when it has received an acceptable carrier signal over the telephone line. If the acceptable carrier signal is lost, the modem de-asserts this signal.

Please read all restrictions and disclaimers.


Determining Your Modem Type: Motorola SM56 Software Modem User's Guide

There are three different SM56 modem types, and each supports a different feature-set. You can check which modem you have by opening the Windows Control Panel, then double click on the Modems icon. On the application’s main window, the product name of your installed modem is displayed. Using the table below, find your Product Name in column 1. Column 2 lists the type of modem you have installed, while column 3 lists the different modem features.

Product Names | Modem Types | Features
Motorola SM56 PCI Fax Modem Motorola SM56 AC-L Modem Motorola SM56 AC-L(s) Modem Motorola SM56 AC-L(v) Modem | Data/Fax only | • All data and fax modes • No telephone answering machine (TAM) • No caller ID • No distinctive ring • No speakerphone
Motorola SM56 PCI Voice Modem Motorola SM56 AC-L(s) Voice Modem Motorola SM56 AC-L(v) Voice Modem | Data/Fax/TAM | • All data and fax modes • Telephone answering machine (TAM) • Caller ID • Distinctive ring • No speakerphone
Motorola SM56 PCI Speakerphone Modem Motorola SM56 AC-L(s) Speakerphone Modem Motorola SM56 AC-L(v) Speakerphone Modem | Data/Fax/TAM/Speakerphone | • All data and fax modes • Telephone answering machine (TAM) • Caller ID • Distinctive ring • Full-duplex speakerphone


Diagnostic Test: Motorola SM56 Software Modem User's Guide

If there is a communications problem, run a quick test to determine whether the modem is responding to commands from the computer, as follows.

1. In the Windows taskbar, select Start; then Settings; then Control Panel. Open the Modems icon.

2. Select the Diagnostics tab.

3. Highlight the port associated with the modem.

4. Select More Info. This test sends AT commands to the modem. The modem’s responses should appear. If they do not, close open applications and restart the computer. If you find the same communications problem, continue with the LAL test, next.

For further information, you can run a Local Analog Loopback (LAL). The LAL tests whether the modem is passing error-free data to and from the locally-connected computer.

To run an LAL test:

1. Remove the telephone line connector from the modem's line input connector.

2. Run a communications application that provides a terminal emulation mode. For example, the HyperTerminal application, found on computers that have Windows, offers terminal emulation mode.

3. Issue the AT&F command to set the modem to factory default options. OK appears.

4. Issue the ATS46=23 command.

5. Issue the AT&T1 command (the characters may not appear as you type). Wait for ten seconds.

6. Begin typing on the keyboard. The characters you type should appear.

7. Enter +++ OK appears.

8. Enter the ATH (hang up) command to end the LAL test.

If the characters that you typed did not appear properly, close running applications and restart the computer. If you find the same communications problem, report the problem to your personal computer or modem vendor.


Dial Modifiers: Motorola SM56 Software Modem User's Guide

The modem supports the following dial modifier characters. Modifiers are used in a dial string to let the modem handle situations such as the use of a calling card, accessing outside lines when located within a PBX system, and using pulse dialing.

This Character: | Has This Name: | And Causes the Modem To:
@ | Quiet Answer | Wait for one or more rings, then five seconds of silence; then proceed with dial string
H | Disconnect | Disconnect from the telephone line.
K k , < | Pause Delay | Pause; the default time is three seconds
P | Pulse Dial | Use pulse dialing
R | Reverse | Enter Answer mode immediately after dialing; use when the remote modem is originate-only
T | Tone Dial | Use tone dialing
W w | Dial Wait | Pause until it detects a dial tone
; | Command Mode | Return to command mode after dialing, without breaking the connection established. Permits transmission of numbers as tones.
!& | Flash | Flash hook. Enables PBX dialing features.


Dial String: Motorola SM56 Software Modem User's Guide

A series of characters that specify a number to dial and actions for the modem to take while dialing.

Composed of numerals and special characters.


Distinctive Ring (US only): Motorola SM56 Software Modem User's Guide

NOTE: This feature is not available on Data/Fax modems.

This modem can detect the ring patterns that are generated by the Distinctive Ring service feature, which is available from many telephone companies. Check with your telephone company for details.

With Distinctive Ring, multiple telephone numbers are assigned to our telephone line. Each number, when called, generates a different ring pattern. This allows you to use one phone line for all types of calls—voice, data, and fax.

The modem transfers the Distinctive Ring data to the communications application. Thus the modem can route calls to the appropriate application. For example, when a caller dials your fax number, the modem activates your fax application.

Back to Contents Page

Distinctive Ring (US only)


Disconnect Reasons and Codes: Motorola SM56 Software Modem User's Guide

When the modem disconnects from the telephone line, it generates and saves a Disconnect Reason message. To display the Disconnect Reason message for the most recent disconnected call, issue the ATI5 command in your communications application. One of the following messages appears.

Disconnect Reason Message

English:

None

DTR DROP

ATH RECEIVED

REMOTE DISCONNECT

OFF-LINE TEST

TRAINING FAILURE

EC LOCAL REQUEST

ALREADY CONNECTED

DIAL ABORTED

BUSY TONE DETECTED

NO DIALTONE

DIAL ABORTED - INCOMING CALL

IMPROPER DTR STATE

PHONE NUMBER BLACKLISTED

RETRAIN THRESHOLD

SEMICOLON DETECTED

ABT TIMEOUT - NO RINGBACK

ABT TIMEOUT - RING BACK RECEIVED

ABT TIMEOUT - NO CALL PROGRESS

ABT TIMEOUT - NO ANSWER

BUSY AFTER RING BACK

EC - TRANSMISSION LIMIT

EC - REMOTE REQUESTED

EC - NO VALID PACKET RECEIVED

EC - ESTABLISHMENT ERROR

EC - ACCEPTOR TIMEOUT

EC - NEGOTIATION FAILURE

EC - PROTOCOL VIOLATION

EC - BAD PARAMETER

EC - DATA COMPRESSION ERROR

FSK RELIABLE INVALID

DTE INACTIVITY TIMEOUT

EC REMOTE NO PSTN

RETRAIN TIMEOUT

VOICE DISCONNECT - VLS = 0

VOICE TO FAX/DATA SWITCH

UNKNOWN

Table 1: Disconnect Reasons and Codes


DOS Box Applications Support: Motorola SM56 Software Modem User's Guide

The SM56 modem supports applications that run in a Windows 98 DOS box.

To enable DOS Box support, open the Modem icon in the Windows tray and select the Enable DOS Box item. You do not need to restart Windows.

When setting up your DOS-based application to communicate with the modem, use the standard IRQ and base I/O information for the COM port number. Standard IRQs and base I/Os are as follows:

COM Port IRQ Base I/O

COM1 4 3F8

COM2 3 2F8

COM3 4 3E8

COM4 3 2E8

The modem uses two IRQs to support DOS-based applications:

• The standard DOS IRQ, as listed above

• The IRQ listed in the Resource tab of the modem’s Properties Sheet (Control Panel, System icon, Device Manager tab)

Ensure that these are assigned different IRQs when setting up your DOS-based applications. If necessary, change the modem’s IRQ, by selecting the Change Settings button on the modem’s Resource tab.


DOS-Based Games and Applications: Motorola SM56 Software Modem User's Guide

Command Strings

You can use the modem with DOS-based games and other applications. Most have provisions for adding an unsupported modem to their supported-modem list. Others let you enter in information about the modem in order to use it. The information items that such applications may need are as follows.

• Initialization string - for setting the modem to a known state

• Hang-up string - for terminating a phone call

• Dialing string - for instructing the modem to initiate a phone call

• Answer string - for instructing modem to answer a phone call

• COM port rate - for sending serialized data is sent to the modem

Command Strings

You can use the following command strings with the modem.

Initialization: AT&F

Initialization with games that require that the modem does not perform error correction and data compression: ATS46=23 AT&F\N0

• Hang-up: ATH0

• Dialing string: ATDT

• Answer string: ATA

• COM port rate: 115,200

NOTE: Do not put spaces between commands.

For more information on enabling Windows 98 DOS support, see DOS Box Applications Support.


DSR: Motorola SM56 Software Modem User's Guide

Data Set Ready signal. The modem asserts this signal to the computer when it is ready to enter the data transmission phase.

Please read all restrictions and disclaimers.


Dual Tone Multi-Frequency: Motorola SM56 Software Modem User's Guide

Method used by the telephone system to communicate the keys that are pressed.

Please read all restrictions and disclaimers.


DTR: Motorola SM56 Software Modem User's Guide

Data Terminal Ready signal. The computer asserts this signal to the modem when it is ready to accept data.


Event Reporting Word: Motorola SM56 Software Modem User's Guide

You can use the AT+VEM command to define events on which to report. The list is encoded as a word composed of the following bits.

NOTE: All events are enabled by default and indicated by the underlined bit number.

A 1 in a bit-position indicates an event is reported.

A 0 in a bit-position indicates an event is not reported.

Read bits from right (Bit 0) to left (Bit 32).

Blank table entries are unsupported events.

Bit | Signal
0 | Caller ID (effective only where function is supported by the phone company. Not supported on Data/Fax modems.
1 |
2 | Distinctive Ring (effective only where function is supported
3 | RING
4 | DTMF Detection
5 | Receive Buffer Overrun
6 | Fax Calling
7 | Data Calling
8 |
9 | Presumed Hang-Up (SILENCE) Time-Out
10 | Presumed End-of-Message (QUIET) Time-Out
11 |
12 |
13 |
14 |
15 |
16 |
17 |
18 | Ring Back
19 | BUSY
20 | DIALTONE
21 |
22 |
23 | Playback Buffer Underrun
24 |
25 | Fax or Data Answering Modem Detected
26 |
27 | Voice Detected
28 |
29 |
30 |
31 |
32 |


EC: Motorola SM56 Software Modem User's Guide

Error-Correction


Fax Service Class 1: Motorola SM56 Software Modem User's Guide

The modem supports Group 3 Facsimile Service Class 1, as defined in the EIA/TIA-578-A specification. With fax software, you can use your computer and the modem to send and receive fax transmissions. If you are having trouble with faxing, see the section on AT+ commands, which control fax operation.


Contents: Motorola SM56 Software Modem User's Guide

Motorola SM56 Software Modem User's Guide

Introduction
Determining Your Modem Type
V.90/V.92 and K56flex
Technical Support
Telephone Connectors
Installing or Re-Installing the Modem
Uninstalling and Upgrading the Modem
Application Compatibility
DOS Box Applications Support
DOS-Based Games and Applications
Fax Service Class 1
Caller ID
Distinctive Ring
Dial Modifiers
Result Codes and Connect Messages
AT Commands – Basics
+++ (Plus-Plus-Plus) Commands
AT and AT& (Ampersand) Commands
AT% (Percent) and AT (Backslash) Cmds
AT* (Asterisk) Commands
AT+ (Plus) Commands
ATS (S-Register) Commands
AT#UD Unimodem Diagnostic Command
Event Report Word
Troubleshooting
Disconnect Reasons and Codes
Diagnostic Test
Uninstalling the Modem
How to Add AT Commands

Information in this document is subject to change without notice.
© 2002 Motorola. All rights reserved.

Trademarks and trade names may be used in this document to refer to either the entities claiming the marks and names or their products. Motorola disclaims any proprietary interest in trademarks and trade names other than its own.


Installing or Re-Installing the Modem: Motorola SM56 Software Modem User's Guide

Requirements • Installing the Modem: Hardware • Installing the Modem: Software • Windows 98, Windows 2000, and Windows XP Installation • Windows Millenium • Windows NT 4.0 • Recovering from an Install Abort/Cancel

The SM56 Modem is typically pre-installed on your computer, but you can re-install it.

CAUTION: Use only one card in the computer.

Requirements

The modem operates on a personal computer equipped with the following:

• Windows 98, Windows Millenium, Windows NT 4.0, Windows 2000, and Windows XP operating systems

• Any of the following processor/cache memory configurations:

- 150 MHz Pentium® or faster CPU (200 MHz, recommended for V.90 operation)

- 233 MHz AMD K6® or faster CPU with 256K L2 cache memory

- 266 MHz Cyrix® MII or faster CPU with 256K L2 cache memory

- 266 MHz Intel® Celeron or faster CPU

• 8 MB hard disk space

• 16 MB RAM - for Windows 98, Windows Millenium

• 32 MB RAM - for Windows 2000, Windows NT 4.0, Windows XP

The SM56 modem requires:

• One vacant 32-bit PCI slot or one AC-Link slot (for SM56 AC-L)

• One available IRQ: 3 through 15 for PCI modems

• For Data/Fax/Speakerphone and Data/Fax/TAM modems, a compatible sound card.

Installing the Modem

Part 1: Hardware Installation

Install the modem as follows:

1. Print this Help topic so that you can refer to the hard copy.

2. Power down the computer. Unplug the power cable.

3. Open the computer and insert the modem board into a PCI or AC-Link slot.

4. Connect the modem to an analog telephone line jack using a telephone cable.

5. Turn on the computer.

Part 2: Software Installation

NOTE: Windows Plug and Play assigns the modem a COM port number. To support older software applications and Windows 9x DOS games the SM56 installation software attempts to negotiate a COM port number in the range of 1-4.

Windows 98, Windows 2000, and Windows XP Installation

NOTE: The Install Wizard may vary slightly with different versions of the operating system and different service packs.

On starting Windows for the first time after installing the SM56 modem board, the Windows Configuration Manager detects the new hardware, assigns resources to it, and then displays a window requesting the modem software drivers. This indicates that the Configuration Manager is looking for the information (INF) file, which contains the following information about the modem,

• device type (modem)

• device driver information (the name of the driver that will control the modem)

• AT command/response sets

Install the software as follows:

• In response to the request window. Select Driver from Disk Provided by Hardware Manufacturer ( Have Disk, or Install from a list or specfic location (Advanced) depending on the OS version) and browse to where the SM56 drivers are located. Windows should find the information on the disk and identify the device as a SM56 Modem. It then copies the files from the install disk to the computer and completes the installation.

• On Data/Fax/TAM and Data/Fax/Speakerphone modems, another device is found after the modem has been installed. Windows notifies you that it has found a Serial Wave Device for the modem and prompts for a Wave Device driver. Re-point to the SM56 driver location and click OK.

When these two devices are installed, the SM56 Modem Setup program runs.

The modem setup program does not prompt for user input during installation. It auto-detects the installed OS country and language selections and defaults the install to those. An upgrade from a previous driver build leaves these settings as before.

Windows Millenium

After installing the SM56 modem board in a Windows Millennium PC or after doing a complete modem uninstall, (via Add/Remove Programs in the Control Panel), the next time you boot the PC the PnP wizard kicks in. Even though you point it to the location of the correct driver for Millennium, by default it still searches through all removable media (CD’s, floppy drivers, ZIP drives, etc.). The first driver it finds that matches the PnP ID of the modem board Millennium will go ahead and install that driver. This driver could be for another operating system, like Windows 2000. Of course, when this happens the resulting installed modem will not work. To avoid this happening, follow these Windows Millennium installation steps:

1. PnP Manager detects the new hardware:

Figure1. New Hardware Found

2. Next Windows will prompt you with the following dialog box:

Figure 2. Add New Hardware Wizard

Click on the radio button to select "Specify the location of the driver (Advanced)" as illustrated by the arrow above. Then click "Next".

3. Next, the following window appears to ask you where the modem drivers are located:

Figure 3. Add New Hardware Wizard

  • Click the "Removable Media (Floppy, CD-ROM…)" check box to de-select it. Please make sure that this box is not checked.
  • Click the "Specify a location" box to select it.
  • Click on the Browse button and point to the location of the correct SM56 modem drivers for Windows Millennium.

4. Clicking on the Browse button in step [3] gets you to the following screen:

Figure 4. Browse for Folder

(Note: This example shows CD-ROM driver install from folder Drivers\WinME on the CD)

  • Single click the ‘+’ sign next to the CD-ROM drive letter (in this case "E:" drive). This opens out the folder list on the CD-ROM, and the "+" sign turns into a "-" sign.
  • Single click the "+" sign next to the "drivers" folder. This opens out the folder to show the sub-folders.
  • Single click "WinME" sub-folder to highlight it.
  • Click "OK" button to complete your selection

5. The next install window appears:

Figure 5. Add New Hardware Wizard

Click "Next".

6. The following window appears:

Figure 6. Add New Hardware Wizard

Click "Next" to begin file copying and modem installation.

7. When complete the following window appears:

Figure 7. Add New Hardware Wizard

This indicates that the first part of the modem installation is complete. Click "Finish".

8. Windows now detects a "Modem Device" and pops the following window:

Figure 8. Add New Hardware Wizard

No intervention is required. Windows automatically finds the drivers and installs them, just sit back and wait a few seconds. When complete Windows will return to the Windows desktop, the modem is now completely installed.

NOTE: If the incorrect modem driver set is already installed first perform a complete modem uninstall (via Add/Remove Programs in the Control Panel), then restart the PC and follow steps [1] through [8] above.

Windows NT 4.0 Installation

Important: | The SM56 software for Windows NT is Data/Fax only, there is no speakerphone or TAM supported.
Important: | Make sure you have the NT 4.0 modem drivers. They are different than those for Windows 9x, XP, or Windows 2000.

Windows NT 4.0 does not fully support plug and play (PnP). Therefore, after installing the modem board in the computer and booting, the operating system will not automatically recognize that new hardware is present. You must manually install the modem by running sm56set.exe from the distribution media. This install program will automatically add a new COM port, install the modem, then assign it to that new COM port. When installation is complete you will be prompted to Restart the PC. You must do this before using the modem.

Important:

There is no Upgrade application for Windows NT 4.0. To upgrade to a new version of the modem, you must first uninstall the previous version (Run uninstall from Add/Remove Programs in the Control Panel), then do a new installation as described in the previous paragraph.

Recovering from an Install Abort/Cancel

During modem software installation Windows provides a message box with a user-selectable Cancel (or Abort) button. If this button is clicked while the modem software installation is running a partial install of the modem results. This partial modem install is not guaranteed to function correctly.

To fully "clean" the system you should:

1. Go to the Windows Control Panel

2. Select Add/Remove Programs

3. Select the SM56 Modem

4. Click Remove

5. Restart the PC

On restart Windows Plug and Play will re-detect the modem. Point the install wizard to the modem drivers folder and allow the complete install to finish. Your modem will now be functional.


Installing or Re-Installing the Modem: Motorola SM56 Software Modem User's Guide

Requirements • Installing the Modem: Hardware • Installing the Modem: Software • Windows 98, Windows Millenium, and Windows 2000 Installation • Recovering from an Install Abort/Cancel

The SM56 Modem is typically pre-installed on your computer, but you can re-install it.

CAUTION: Use only one card in the computer.

Requirements

The modem operates on a personal computer equipped with the following:

• Windows 98, Windows Millenium, and Windows 2000 operating systems

• Any of the following processor/cache memory configurations:

- 150 MHz Pentium® or faster CPU (200 MHz, recommended for V.90 operation)

- 233 MHz AMD K6® or faster CPU with 256K L2 cache memory

- 266 MHz Cyrix® MII or faster CPU with 256K L2 cache memory

- 266 MHz Intel® Celeron or faster CPU

• 8 MB hard disk space

• 16 MB RAM - for Windows 98 or Windows Millenium

• 32 MB RAM - for Windows 2000

The SM56 modem requires:

• One vacant 32-bit PCI slot

• One available IRQ: 3 through 15 for PCI modems

Installing the Modem

Part 1: Hardware Installation

Install the modem as follows:

1. Print this Help topic so that you can refer to the hard copy.

2. Power down the computer. Unplug the power cable.

3. Open the computer and insert the modem board into a PCI slot.

4. Connect the modem to an analog telephone line jack using a telephone cable.

5. Turn on the computer.

Part 2: Software Installation

NOTE: Windows Plug and Play assigns the modem a COM port number. To support older software applications and Windows 9x DOS games the SM56 installation software attempts to negotiate a COM port number in the range of 1-4.

Windows 98, Windows Millenium, and Windows 2000 Installation

NOTE: The Install Wizard may vary slightly with different versions of the operating system and different service packs.

On starting Windows for the first time after installing the SM56 modem board, the Windows Configuration Manager detects the new hardware, assigns resources to it, and then displays a window requesting the modem software drivers. This indicates that the Configuration Manager is looking for the information (INF) file, which contains the following information about the modem,

• device type (modem)

• device driver information (the name of the driver that will control the modem)

• AT command/response sets

Install the software as follows:

• In response to the request window. Select Driver from Disk Provided by Hardware Manufacturer (or Have Disk, depending on the OS version) and browse to where the SM56 drivers are located. Windows should find the information on the disk and identify the device as a SM56 Modem. It then copies the files from the install disk to the computer and completes the installation.

The modem setup program does not prompt for user input during installation. It auto-detects the installed OS country and language selections and defaults the install to those. An upgrade from a previous driver build leaves these settings as before.

Recovering from an Install Abort/Cancel

During modem software installation Windows provides a message box with a user-selectable Cancel (or Abort) button. If this button is clicked while the modem software installation is running a partial install of the modem results. This partial modem install is not guaranteed to function correctly.

To fully "clean" the system you should:

1. Go to the Windows Control Panel

2. Select Add/Remove Programs

3. Select the SM56 Modem

4. Click Remove

5. Restart the PC

On restart Windows Plug and Play will re-detect the modem. Point the install wizard to the modem drivers folder and allow the complete install to finish. Your modem will now be functional.

Please read all restrictions and disclaimers.


Result Codes and Connect Messages: Motorola SM56 Software Modem User's Guide

The modem sends messages to the computer that indicate connection status. The communications application uses this information to track the progress of a connection and take the appropriate actions.

Message content and format is determined by:

• The Result Code Display (ATQ ) parameter option, which enables result codes to display

• The Result Code Format (ATV ) parameter option, which determines the result message format (long-form text messages or short-form numeric codes)

• The Call Progress Reporting (ATX ) parameter option, which determines the types of messages displayed

• The Connect Message (AT\V ) parameter option, which determines the types of information displayed within a connect message

The Result Code Display parameter must be enabled (ATQ=1) for the modem to generate any messages.

The following numeric codes or text messages are sent, according to the Call Progress Reporting (ATX) option. The connect messages shown below can be generated when the Connect Message parameter (AT\V) is set to a Rate-Only option (AT\V0 or AT\V2).

Code | Text Message | Call Progress Reporting (ATX) Option
0 | OK | 0,1,2,3, or 4
1 | CONNECT 75 | 0
NOTE: If Call Progress=0, the receipt of numeric code 1 indicates only that a connection has been made. If Call Progress=1, 2, 3, or 4, the receipt of numeric code 1 indicates a connection was made at 75 bps.
2 | RING | 0, 1, 2, 3, or 4
3 | NO CARRIER | 0, 1, 2, 3, or 4
4 | ERROR | 0, 1, 2, 3, or 4
5 | CONNECT 1200 | 1, 2, 3, or 4
6 | NO DIALTONE | 2 or 4
7 | BUSY | 3 or 4
8 | NO ANSWER | 0, 1, 2, 3, or 4
10 | CONNECT 2400 | 1, 2, 3, or 4
11 | CONNECT 4800 | 1, 2, 3, or
12 | CONNECT 9600 | 1, 2, 3, or 4
13 | CONNECT 600 | 1, 2, 3, or 4
20 | CONNECT 300 | 1, 2, 3, or 4
22 | CONNECT 7200 | 1, 2, 3, or 4
23 | CONNECT 12000 | 1, 2, 3, or 4
24 | CONNECT 14400 | 1, 2, 3, or 4
25 | CONNECT 16800 | 1, 2, 3, or 4
26 | CONNECT 19200 | 1, 2, 3, or 4
27 | CONNECT 21600 | 1, 2, 3, or 4
28 | CONNECT 24000 | 1, 2, 3, or 4
29 | CONNECT 26400 | 1, 2, 3, or 4
30 | CONNECT 28800 | 1, 2, 3, or 4
31 | CONNECT 31200 | 1, 2, 3, or 4
32 | CONNECT 33600 | 1, 2, 3, or 4
34 | CONNECT 38400 | 1, 2, 3, or 4
35 | CONNECT 57600 | 1, 2, 3, or 4
36 | CONNECT 115200 | 1, 2, 3, or 4
37 | CONNECT 32000 | 1, 2, 3, or 4
38 | CONNECT 34000 | 1, 2, 3, or 4
39 | CONNECT 36000 | 1, 2, 3, or 4
40 | CONNECT 38000 | 1, 2, 3, or 4
41 | CONNECT 40000 | 1, 2, 3, or 4
42 | CONNECT 42000 | 1, 2, 3, or 4
44 | CONNECT 44000 | 1, 2, 3, or 4
46 | CONNECT 46000 | 1, 2, 3, or 4
48 | CONNECT 48000 | 1, 2, 3, or 4
50 | CONNECT 50000 | 1, 2, 3, or 4
52 | CONNECT 52000 | 1, 2, 3, or 4
54 | CONNECT 54000 | 1, 2, 3, or 4
56 | CONNECT 56000 | 1, 2, 3, or 4
58 | CONNECT 58000 | 1, 2, 3, or 4
60 | CONNECT 60000 | 1, 2, 3, or 4
61 | CONNECT 28000 | 1, 2, 3, or 4
62 | CONNECT 29333 | 1, 2, 3, or 4
63 | CONNECT 30666 | 1, 2, 3, or 4
64 | CONNECT 33333 | 1, 2, 3, or 4
65 | CONNECT 34666 | 1, 2, 3, or 4
66 | CONNECT 37333 | 1, 2, 3, or 4
67 | CONNECT 38666 | 1, 2, 3, or 4
68 | CONNECT 41333 | 1, 2, 3, or 4
69 | CONNECT 42666 | 1, 2, 3, or 4
70 | CONNECT 45333 | 1, 2, 3, or 4
71 | CONNECT 46666 | 1, 2, 3, or 4
72 | CONNECT 49333 | 1, 2, 3, or 4
73 | CONNECT 50666 | 1, 2, 3, or 4
74 | CONNECT 53333 | 1, 2, 3, or 4
75 | CONNECT 54666 | 1, 2, 3, or 4

NOTE: Rates are bits/second

Table 1: Result Codes

The Connect Message can also be configured to indicate such information as:

• The modem modulation mode

• The error-correction type and data-compression method used for a connection

When the Call Progress Reporting parameter (ATX) is set to a non-zero option, the types of connect messages that can be sent, based on the Connect Message (AT\V) option, are as follows. There are no numeric codes for these messages.

Connect Message (AT\V) Option

Text Message

1

CONNECT rxrate

CONNECT rxrate/ec

CONNECT rxrate/ec/dc

3

CONNECT rxrate

CONNECT rxrate/ec

CONNECT rxrate/ec/dc

4

CONNECT rxrate/mode

CONNECT rxrate/mode/ec

CONNECT rxrate/mode/ec/dc

CONNECT rxrate/txrate/mode

CONNECT rxrate/txrate/mode/ec

CONNECT rxrate/txrate/mode/ec/dc

Where rxrate = receive data rate in bits per second

Where txrate = transmit data rate in bits per second

Where dc = one of V42BIS, MNP5, V44

Where mode = one of V34, V32BIS, V32, V23, V22BIS, V21, K56flex™ , V.90, V.92, B212, B103

When AT\V is set to 0 or 1, the connect message shows the rate at which the computer communicates with the modem—the DTE rate.

When AT\V = 2, 3 or 4, the connect message shows the rate at which the modem communicates with the remote modem—the DCE rate. An asymmetric connection occurs when the receive rate is different from the transmit rate. In this case, the receive rate is shown (followed by the transmit rate, if AT\V = 4).

Table 2: Connect Messages

Example: Other Connect Messages

The modem can generate the following messages when the corresponding options are enabled.

If This Option is Enabled | The Modem Can Generate this Message | Example
+ILRR | +ILRR: <rate>[,<rx_rate>] | +ILRR: 19200
+MR | +MCR: <carrier> +MRR: <rate>[,<rx_rate>] NOTE: <carrier> values are the same as the first parameter of the AT+MS command. | +MCR: V32B +MRR: 33600
AT+ER | +ER:NONE +ER:LAPM +ER:ALT |
T+DR | +DR:NONE +DR:V42B +DR:V42B RD +DR:V42B TD |

Table 3: Other Connect Messages

Other Messages

The modem can generate the following messages.

Numeric Code | Text Message | Meaning
+F4 | +FCERROR | Invalid fax tone or data carrier detected; modem returned to command state.
ERRM=ICLID_202 | ERRM=ICLID_202 | Caller ID information from the phone company was corrupted and therefore could not be provided.

Table 4: Other Generated Messages


Technical Support: Motorola SM56 Software Modem User's Guide

For telephone technical support, contact your personal computer or direct modem supplier.

If you haven’t checked the Troubleshooting section, do that first.


Telephone Connectors: Motorola SM56 Software Modem User's Guide

Most modems have two RJ-11 telephone connectors, labeled LINE (green) and PHONE.

To set up the modem, connect a telephone cable from a telephone service outlet to the LINE connector. Optionally, connect a telephone set to the PHONE connector. A connected telephone operates normally, even if the computer is powered off.

You cannot use this telephone if the modem is connected. Attempting to use it while online may drop the modem connection.


Troubleshooting: Motorola SM56 Software Modem User's Guide

If there is a problem in making or receiving a call or transmitting data, and your communications application does not explain the problem, check the following list of symptoms and tips.

Windows 98 DOS box applications do not work with the modem

If DOS box applications do not work, try:

1. Open the Control Panel.

2. Double click the System icon.

3. Expand the Modem branch.

4. Double click the Motorola SM56 modem.

5. Select the Modem tab. Make a note of the COM port number.

6. Select the Resources tab. Make a note of the IRQ number listed.

7. For DOS support to operate correctly, the SM56 modem cannot occupy the standard IRQ for the COM port number.

8. Uncheck the Use Automatic Resources check box.

9. Double click on the Interrupt Request label and change the IRQ to a different number that is not in conflict with another device. (If there is no free IRQ: free one, or change other device IRQ levels to free a non-standard IRQ).

There is no dial tone

1. Ensure that the telephone cable is securely connected at both ends.

2. Unplug the telephone line cable from the computer, and connect it directly to a telephone from the wall outlet. Check for a dial tone. If there is none, the problem is in the telephone line or system. Call the service provider.

The modem cannot complete a connection to another modem

1. Ensure that your modem is dialing the correct number. Ensure that you've specified the correct area code, if one is required.

2. Determine whether the remote modem is correctly configured to communicate with yours.

The modem does not answer incoming calls

1. Ensure that the automatic answer parameter is set to one of the enabled options, using the ATS0 command (ATS0=1 to answer after one ring, ATS0=2 to answer after two rings, and so on).

2. Ensure that no other devices, such as fax or answering machines, are answering calls before the modem does.

The modem disconnects while transmission is in progress

1. Ensure that the telephone cable is securely connected at both ends.

2. Ensure that call-waiting is disabled. In most areas, the command *70 or #70 disables call-waiting. Check with your telephone company for the correct key sequence. (With call-waiting, the incoming call's click sound may be disrupting your call.)

Data is not transmitted or received for unusually long periods of time

1. Re-dial the call. (The telephone line connection may be poor.)

2. Try another ISP number, the server could be busy.

3. Call your ISP and find out if they are having server problems or any suggestions why data transmission is lethargic.

The computer runs slower than usual

1. Close any open applications that you are not using.

You cannot enter tone selections successfully when calling tone-driven applications

1. When dialing a remote system that requires you to enter selections using the telephone keys, such as a voice-mail depot or bank-account information provider, you can lengthen the duration of the tones your modem sends, so that the remote system can detect them better. To adjust DTMF tone length, use the AT+VTDn command, where n specifies the tone duration.

The modem does not respond to AT commands

1. Ensure that your communications software is configured to use the same COM port as the modem's COM port.

2. Reset modem parameters to default options by entering AT&F; then re-enter custom options.

The modem responds to commands, but they do not appear on the screen

1. Ensure that the local display echo option is enabled by entering ATE1.

2. Press Enter.

You've installed a new peripheral device; now the modem does not work

1. In the Windows desktop tray, select Start.

2. Select Help. The Windows Help Topics window appears.

3. Select the Contents tab.

4. Select If You Have a Hardware Conflict.

5. A series of troubleshooting actions appears. Follow the appropriate sequence.

You hear feedback (noise) from the PC sound system (Data/Fax/Speakerphone modems)

1. Position the speakers at least three feet (1 meter) away from the microphone.

2. Ensure that the speakers are facing away from the microphone.

3. Turn down the speaker volume.

4. Speak into the microphone at a distance of at least 12 inches (30 cm) from your mouth. Minimize background noise.

5. If there is still feedback, turn off the microphone boost, under the volume control panel.

The modem connects, then meaningless characters appear

1. Open the Control Panel. Double click the Modem icon.

2. Select the Motorola SM56 modem.

3. Click on Properties.

4. Select Connection.

5. Click on Advanced.

6. Check the Use Error Control-Required to Connect box.

The modem cannot connect; the Error Control option is selected

The modem may be connecting at a rate higher than appropriate for the line conditions.

1. Use the AT%B command to limit the SM56 maximum connection rate. (Refer to the AT% commands section for details.)

2. Lower the rate, using AT commands, until the problem is corrected. You can add AT commands to do this; refer to the next section.

The modem is not detected

1. Restart the computer.

2. If after restarting the computer the modem is still not detected, uninstall the modem and reinstall it.


Uninstalling the Modem: Motorola SM56 Software Modem User's Guide

Uninstalling the Modem Software • Uninstalling the Modem Hardware

This section explains how to remove the modem from a personal computer. Uninstalling the modem is a two-step process:

• Uninstall the modem software

• Uninstall the modem hardware

Uninstalling the Modem Software

1. Select Start; then Settings; then Control Panel.

2. Open Add/Remove Programs

3. Select Motorola SM56 Modem Uninstall. Select Add/Remove

Uninstalling the Modem Hardware

1. Shut down the computer.Unplug it from the power source.

WARNING: When removing an internal modem from a personal computer, disconnect the telephone cable and disconnect all power from the personal computer. Allow the modem card to cool for three or four minutes before handling it.

2. Unplug the telephone cables from the modem card connector.

3. Open the computer cover.

4. Remove the modem line interface card.

5. Replace the computer cover. Connect the computer to the power source. Restart the computer.

The uninstall procedure is complete.


Uninstalling and Upgrading the SM56 Modem: Motorola SM56 Software Modem User's Guide

SM56 UnInstall Procedure • SM56 Software Upgrade Procedure • Recovering From an Unsuccessful Upgrade

You can upgrade the software for new features as they become available. In most cases, new hardware is not needed.

SM56 Un-Install Procedure

1. Open the Control Panel.

2. Select Add\Remove Programs.

3. In the dialog box, select Motorola SM56..... Modem Uninstall.

4. Select Add/Remove.

5. Shut down the computer.

6. Remove the SM56 hardware from the computer.

SM56 Software Upgrade Procedure

Upgrade the SM56 modem to a newer version as follows:

1. Obtain the latest software version from your direct modem supplier.

2. Run sm56set.exe and follow the Upgrade Wizard prompts. The upgrade utility retains a backup of your previous modem version in a folder called \Windows\Motorolabak. It also retains the modem COM port, country, and language settings so all communication applications will continue to function correctly.

Recovering From an Unsuccessful Upgrade

If, after an SM56 upgrade, you have problems with the new driver, you can restore your previous SM56 software installation as follows. Perform all of the following steps.

1. Open the Control Panel. Select Add/Remove programs.

2. If Motorola SM56 Modem Uninstall is in the list of installed programs, click on Motorola SM56 Modem Uninstall, then Click Add/Remove to run the uninstall program.

3. Restart the computer.

4. Upon restart, re-install the SM56 modem from the backup directory at \Windows\Motorolabak.

This will reinstall your previous modem software.


V.90/V.92 and K56flex: Motorola SM56 Software Modem User's Guide

V.90/V.92 and K56flex™ technologies allow users to connect to the Internet at rates up to twice as fast as those of V.34 modems. The maximum receive rate is 56Kbps, while the return path connects at up to 48.0 Kbps. This is perfect for Internet connections in which most data is transferred from the Internet to the client computer.

With V.92 technology, users are assured of achieving the highest degree of interoperability with Internet service providers (ISPs), because, following the ITU V.92 Initiative, most ISPs are converting to V.92.

V.92 is the latest, most advanced analog modem technology available today. It provides users with a "broadband-like" Internet experience. V.92 lets you:

• Connect faster to your ISP

• Send data at faster speeds (up to 48Kbps)

• Put your Internet connection on hold while you place or receive a regular phone call. (This requires support from your ISP and call waiting tone service from your telephone company.)

Visit the V.90 and V.92 websites (www.v90.com, www.v92.com) for a wealth of information, including:

• A complete list of ISPs that support V.90/V.92

• Latest news on V.90/V.92

• Technical “white papers” on V.90/V.92

• Frequently Asked Questions (FAQs) about V.90/V.92

To use V.90/V.92, contact your ISP to:

• Ensure that the ISP supports V.90/V.92

• Get a dial-in number for a V.90/V.92 connection

NOTE: 56Kbps rates may not always be achievable, due to adverse line conditions.

When the modem connects to a non-V.90/V.92 head-end:

• If the head-end is K56flex™-compliant, the modem connects at K56flex™ rates.

• If the head-end is X2™-compliant, the modem connects at V.34 rates.